404 and 500 error on log in for wordpress network 3.0.4 after upgrade from wpmu 2.9.2

I upgraded from wpmu 2.9.2 to wp 3.0.4 Network. After upgrading I can not log in to sites, I get 404 and 500 errors after logging. Note, that my wpmu sites were working (as sub-domains) before upgrading.

I tried to do an automatic upgrade and it did not work. So I did a manual upgrade.

Below is the process I followed to upgrade:

1.Deactivated plugins

2.Downloaded the wp 3.0.4 file from wordpress.org/download

3.Deleted the wp-admin and wp-includes folders in my installs root

4.Uploaded the new wp-admin and wp-includes folders from wp 3.0.4

5.Overwrote only the duplicated files in the wp-content folder from the wp 3.0.4. Left the other files in wp-content alone.

6.Uploaded the loose upgrade (3.0.4) files to the root dir.

7. Following the directions on: http://codex.wordpress.org/Create_A_Network

Quote from that page:

“NOTE: If you are currently running a version of WordPress MU, you do not need to complete these steps. your network is already enabled. Once you upgrade to the 3.x branch, you will be prompted to update your .htaccess rules for MultiSite.”

I assumed I could ignore the steps to set up a Network since I was upgrading from WPMU 2.9.2, following these directions.

8.So I did NOT:

Open up wp-config.php and add this line above where it says /* That’s all, stop editing! Happy blogging. */:

define(‘WP_ALLOW_MULTISITE’, true);

9.And I do not see: Network under Tools in my Super Admin. So I do not have the option of selection sub-domain over sub-directory, or setting the server address, network title or email address. I assume these are carried over from WPMU 2.9.2 However, in my Super Admin I do see Sites, Users, etc…same as in WPMU 2.9.2.

10.I find that blogs.dir directory is already created under /wp-content/ with 0755 permissions.

11.I delete blogs.php from /wp-content/.

12.And I update my htaccess to reflect that blogs.php has been moved to wp-includes/ms-files.php by finding:

RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L] and change it to this: RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

13.I add the Nonce salt in my WP install to the wp-config.php twice.

14.Then I logged in as SuperAdmin again and upgraded through Tools and Updated through Super Admin.

NOTE

My wp-config.php does not include 2 lines shown on https://wpmudev.com/wpmu-and-buddypress-installation/creating-a-network-by-enabling-wordpress-multisite/

Instead of:

define( ‘MULTISITE’, true );

I have:

define( ‘DB_Collate’, ”:wink:;

And instead of

define( ‘SUBDOMAIN_INSTALL’, true );

I have:

define( ‘VHOST’, ‘yes’:wink:;

The rest is the same (see below):

$base = ‘/’;

define( ‘DOMAIN_CURRENT_SITE’, ‘sitename.com’ );

define( ‘PATH_CURRENT-SITE’, ‘/’ );

define( ‘SITE_ID_CURRENT_SITE’, 1 );

define( ‘BLOG_ID_CURRENT_SITE’, 1);


Before (in WPMU 2.9.2) I got around my webhost not having wildcard dns enabled by using an external dns provider and by setting up subdomains in cPanel. My external DNS provider has three A records set up:

website.com.

*

www

In my webhost cPanel I have subdomains set up:

ie. subdomain.website.com

The above setup used to work well. Now when I try to log into a subdomain blog site I get 404 and 500 errors. Below is the error log from my webhost (duplicates deleted and x’s added to identifiers):

[Sun Jan 23 15:00:37 2011] [warn] RewriteCond: NoCase option for non-regex pattern ‘-f’ is not supported and will be ignored.

[Sun Jan 23 15:00:42 2011] [error] [client 67.xxx.xxx.xx] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.

[Sun Jan 23 15:00:50 2011] [error] [client 202.xxx.xx.xxx] Request exceeded the limit of 10 internal redirects due to probable configuration error. Use ‘LimitInternalRecursion’ to increase the limit if necessary. Use ‘LogLevel debug’ to get a backtrace.


My current htacccess file is:

RewriteEngine On

RewriteBase /

#uploaded files

RewriteRule ^(.*/)?files/$ index.php [L]

RewriteCond %{REQUEST_URI} !.*wp-content/plugins.*

RewriteRule ^(.*/)?files/(.*) wp-includes/ms-files.php?file=$2 [L]

# add a trailing slash to /wp-admin

RewriteCond %{REQUEST_URI} ^.*/wp-admin$

RewriteRule ^(.+)$ $1/ [R=301,L]

RewriteCond %{REQUEST_FILENAME} -f [OR]

RewriteCond %{REQUEST_FILENAME} -d

RewriteRule . – [L]

RewriteRule ^([_0-…(deleted because I did not know if this was an identifier)

RewriteRule ^([_0-…(deleted because I did not know if this was an identifier)

RewriteRule . index.php [L]

<IfModule mod_security.c>

<Files async-upload.php>

SecFilterEngine Off

SecFilterScanPOST Off

</Files>

</IfModule>


I appreciate any help.