About multi-db plugin (not class)

Hi,

I want to ask; is the multi-db plugin (not class) neccessary for multi-db? Latest version 3.1 haven’t plugin folder.

Edit:Added picture

Thanks.