Autopost not working and I have no users under the autopost

I have configured the plugin and api is successful and the extended permissions are granted but I see no users to choose from under the autopost option. I’m assuming this is why I can’t get the autopost to work. Any help would be great.