buddypress 1.2.5 is compatible to all buddypress plugins here?

Is all buddypress plugins on wpmudev are now compatible with new buddypress 1.2.5? I tried to install new buddypress 1.2.5, but things went awry, awfully bad, anti-splog stopped working, the plugin panel showed buddypress wasn’t activated and the bp-group-calendar and bp-group-email weren’t activated either.

I’m using multdb version 3.0, wordpress 3.0, trying to upgrade buddypress 1.2.4.1 to 1.2.5

How I went about installing new buddypress 1.2.5?

I network deactivated bp-group-email bp-group-calendar, and buddypress.

cd /home/myuser/folder/

unzip buddypress.1.2.5.zip

Chmod 755 buddypress

cd buddypress

find . -type d -exec chmod 755 {} ;

find . -type f -exec chmod 644 {} ;

cd ..

cp -r buddypress /home/myuser/public_html/wp-content/plugins/

went back into admin panel, plugins section

network activated buddypress

network activated bp-group-calendar and bp-group-email

Then I saw a message in admin panel complained anti-splog is not yet ready (something of this sort), and so I re-add the settings, saved settings. Went back into admin panel and saw the same anti-splog message said it’s not ready, went into setting and saw the setting wasn’t there, I had to re-add, but it didn’t matter! Anti-splog failed to work after buddypress update! Went into the admin panel, plugins section and saw that buddypress plugin wasn’t appeared on the list, and bp-group-email and bp-group-calendar wasn’t activated, and the upgrade message for buddypress is still requesting me to upgrade to new buddypress.

What’s going on? Please advice, thank you!