BuddyPress forum posting problem possibly linked to Multi-DB



I am seeing a problem posting to a forum in BuddyPress which I believe

I have linked to Multi-DB through some experiments.

The problem that I am able to reproduce (over successive fresh installs)

is the error message “There was an error when creating the topic” when

attempting to start a new topic.



Please refer to the thread:


The initial 2 messages by the other author exactly describes the problems I was also first having after having customized my install with BuddyPress, Multi-DB and several plugins.

I decided to perform some experiments with fresh installs with only BuddyPres, Multi-DB and no other plugins.



The following is some information on my setup:

Ubuntu 8.04.4 LTS

PHP 5.2.6

MySQL 5.0.51a

WordPress 3.0.4

BuddyPress 1.2.7

Multi-DB 3.0.4

Note: The installs are only on my local machine and not available currently on a web server.



First install without Multi-DB

I start out by installing WordPress 3.0.4 in network mode with subdomains.

I next install BuddyPress 1.2.7 automatically from the Plugin menu.

I enable Forum support with the 1 click install within the BuddyPress menu.

I enable and use the default BuddyPress theme.

Group creation and posting to forums works without any problems.

Second install with Multi-DB

I start from scratch again and follow the steps from the previous section,

additionally adding in the install of Multi-DB 3.0.4.

I set this up for 4096 databases. Everything seems to install correctly

(new databases created and in use, basic operation working). I delete

the original single database to ensure that I am only working off the new

set of 4097 databases (including global db).

Group creation seems to work fine and I am able to create several of them.

I am not seeing the group problems that I initially saw in a fully loaded

(with plugins) configuration referenced in the Background section above.

Posting to forums however does not work at all, consistently producing the

message “There was an error when creating the topic”.



I tried to simplify the configuration as much as possible as described above.

I ran through the installs above (with and without Multi-DB) a couple times

with the same results.

Could one of the developer try to reproduce my results?

If need be, I could prepare a tarball of an example WordPress install with accompanying MySQL database dumps showing the problem.