eNewsletter Installation problem

I am running WordPress 3.8 with wpmu dev 3.4.1

When I installed the eNewsletter plugin I received a “unable to activate plugin” error without any additional information. Obviously the install did not work. I then deleted the plugin and installed again. This time I did not receive an error message, but when I click on eNewsletter in the leftside menu wordpress throws a 500 internal server error.