Having a lot of trouble setting up Membership site

I have been trying to muddle through setting up membership on my site but I am just about to give up.

I have now done this 3 times (installed-uninstalled etc.) with varying degrees of success but let me start with the very first thing that happened as that may be a clue to all problems.

On first install


When installing membership and setting up the membership page options I clicked “Create page” for the register page and it seemed to take forever then I received an error message

===================================

“The page isn’t redirecting properly

Firefox has detected that the server is redirecting the request for this address in a way that will never complete.

This problem can sometimes be caused by disabling or refusing to accept cookies.”

===================================

So I looked into my pages to see if a page had been created and found about 20 Register pages had been created!

Obviously this was strange but I thought I would delete out all barring one and proceed on. This issue occured on all others memebrship pages as well so I did the same delete of extra pages.

So soldering on I was able to get the pages to work, setup my subscriptions and levels and signup a sample user to my premium level. Visitors had a negative rule for certain content and premium level had no rules.

Vistors were being blocked from the restricted content but so were the premium level users!. I then tried setting positive rules for the premium level allowing such content but that didn’t work either.

I am totally confused and frustrated about this and have now tried 3 times. Is ther any chance you could check out my site?

Thanks in advance