Heads Up! WordPress 3.5 Database Issue for Multi DB type installations

Greetings,

After an update to WordPress 3.5 it was discovered that there is a warning that is displayed on the site front end of WordPress installations due to a bug with $wpdb as admitted to by WordPress here: http://wordpress.org/support/topic/err-after-upgrade-to-35

Posted and confirmed by Joe