Permalink is not working after %post_id% switched to %postname%


I have 2 issues with the permalinks, I hope you guys can help me :slight_smile:


I have custom permalink for my custom post type “properties”.

I added the permalink as /huurwoningen/%locations%/%post_id%/

all is working as expected, but now I do need to use %postname% instead of post_id.

when I set it in the permalink setting to %postname%.

The new URL is correct (when i go to I can hover the apartment and the URL is correct as how I want it) but when i visit the page I get 404 page not found.

how can I solve this?

I did reset permalink, change to date and change it back again, remove .htaccess and generate a new one, but still not solving this issue.



I want to remove /category/ in the blog archive

I added dot ( . ) in the category base and save permalink. now the link is correct (the category base is gone) but I get 404 when i visit the page.

I think if issue 1 is solved, it will also solved number 2.

Thank you so much in advance. If you need more info, feel free to ask :slight_smile: