Plug-in: Upgrades does not work, Help?

Hey guys I have the upgrades plug in version 1.4.2 and after following the installation directions and setting it up, I am still not able to see a list of any plug-ins once I create an Upgrade Package. "Plugin One" , "Plugin Two", "Plugin Three" and so on only have the option "none". Did I install the plug in properly? Has anyone else been experiencing this problem?

Would like to hear any kind of input as anything will help

Thanks!