Protection of media files (images) doesn't work for me

I’m creating a gallery of images. One particular feature I’d really like to use is protecting the media files, i.e. the images so that they are masked and nobody can reach their actual directory (for example, instead of /wp-content/uploads/building.jpg one can only see, say, /img/457495739730.jpg).

I’ve configured Downloads/Media according to documentation, leaving Protected groups set to “default” as I want all my images to be protected. Then in the corresponding media settings I specify this protected group to all my images. Finally, I drop the “Downloads” item to the positive rules in all access levels. But when I open the site, all images are still linked to the wp-content/uploads directory, so everybody can see the original location, which is not what I would expect. Please guide me what I’m doing wrong, I really need to resolve this issue. Thanks, Rene.