[SmartCrawl Pro] Smartcrawl slowing site

Issue: website slowed to 21 seconds to load any page

symptoms: slow site, web host saw following in log …

HI Paul Thanks for getting in touch.

This looks to be purely down to wpmu-dev-seo. Essentially we can see literally 29 seconds of looping:

home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php

169471 15:07:45.312083 close(4) = 0

169471 15:07:45.312247 access("/home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php", F_OK) = 0

169471 15:07:45.312477 open("/home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php", O_RDONLY) = 4

<snip>

169471 15:08:14.413799 open("/home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php", O_RDONLY) = 5

169471 15:08:14.414238 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.414269 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.414325 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.414352 mmap(NULL, 7949, PROT_READ, MAP_SHARED, 5, 0) = 0x7f28f163f000

169471 15:08:14.414446 munmap(0x7f28f163f000, 7949) = 0

169471 15:08:14.414480 close(5) = 0

169471 15:08:14.414515 access("/home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php", F_OK) = 0

169471 15:08:14.414712 open("/home/sites/4a/2/2bfd714316/public_html/wp-content/plugins/wpmu-dev-seo/class-mappings.php", O_RDONLY) = 5

169471 15:08:14.415074 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.415104 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.415131 fstat(5, {st_mode=S_IFREG|0644, st_size=7949, …}) = 0

169471 15:08:14.415157 mmap(NULL, 7949, PROT_READ, MAP_SHARED, 5, 0) = 0x7f28f163f000

169471 15:08:14.415245 munmap(0x7f28f163f000, 7949) = 0

169471 15:08:14.415271 close(5) = 0

169471 15:08:14.426874 sendto(3, "2473SELECT tt.term_id, tt.term_taxonomy_id FROM wp_terms AS t INNER JOIN wp_term_taxonomy as tt ON tt.term_id = t.term_id WHERE t.term_id = 6 AND tt.taxonomy = 'category'", 171, MSG_DONTWA

IT, NULL, 0) = 171