[Smush Pro] Media Library not loading images due to 500 error

I’m having some trouble with my Media Library which I believe may be connected to Smush Pro. When I try to create a blog post or edit/create a page, images in my Media Library will not load. The file count says 14,000+ but there are no thumbnails. It works as expected when I disable Smush Pro.

We opened the browser console and found that it shows a 500 Internal Server Error while trying to load wp-admin/admin-ajax.php. Upon enabling WP_DEBUG, we found the following Fatal Error:

[26-Sep-2018 04:19:45 UTC] PHP Fatal error: Uncaught Error: Call to undefined method Amazon_S3_And_CloudFront_Pro::is_attachment_served_by_s3() in /home/{username}/public_html/wp-content/plugins/wp-smush-pro/lib/integrations/class-wp-smush-s3.php:265

We’re using Smush Pro’s integration with WP Offload S3 (premium) to store images to Amazon S3. We have already tried a plugin conflict test. Upon switching to a default WP theme and deactivating all plugins except WPMU DEV Dashboard, Smush Pro and WP Offload S3, the issue still persists. Additionally, deactivating WP Offload S3 still doesn’t make the Media Library load images, but shows a different error in the console, it shows 404 while loading all the images.

The WP Offload S3 plugin has had an update two days ago and I’m assuming the issue might have been introduced following the update. I’ve already reached out to their support but they haven’t responded yet. Please note that the issue doesn’t exist when I disable Smush Pro. So, I think it might have something to do with the integration compatibility with the latest update.

Please advice.