Trouble with Google Analytics

I’m having trouble with Google Analytic plugin.

Opps forgot to give the error code found on wp-admin for sub-domain blogs

Fatal error: Cannot break/continue 1 level in /home/dapadoo/public_html/wp-content/plugins/google-analytics-async/google-analytics-async.php on line 160

I’ve removed the old plugin that was in the mu-plugins folder

I’ve updated to the newest version of the plugin.

When I activate either way, activate or network activate an error message appears in place of wp-admin with all sub-domain blogs.

I’ve tried with or with out supporters able to use it.

The only way I’ve been able to get the wp-admin page to reappear in sub-domain blogs is to remove the Google Analytic plugin completely.

Any one now what the problem is?

Could or is this one of the plugins that’s not going to work until wp3.1?

If so, what version do I need to go back to? There were 3 released on 1-11-11