True or False: The BBpress forums packaged with BuddyPress are 'old and unsupported'?

Hi Guys,

I’m currently developing a website on WordPress/BuddyPress. We’re approaching soft launch but I’m having problems getting the forums to work – I’m 95% certain that this is a compatibility issue with our LAMP environment which is running PHP 5.3 as the forums are working fine on a PHP 5.2 server.

Could someone please tell me if the following statement is true?

The forum plug-in is old and unsupported. You will need to find a newer one and adapt the site accordingly.

As far as I’m aware, the bbpress forums packaged with BuddyPress are still supported and should be working fine?

Any help would be hugely appreciated!

Cheers.